Resolved
All delayed events related to subscription/add-on activation, porting, or eSIM installation status are fully processed. We are now taking actions to ensure such issue would be caught automatically by our CI pipeline in the future.
Monitoring
We've identified an issue with a recent change that prevented our background processing workers to function. We've reverted the workers version to an older state, which immediately resumed the workers and processed the backlog.
We're now monitoring the stability of the system.
Investigating
We have observed delays in processing various events within our systems. As a result subscription activations, portings and other asynchronous processes may all experience delays. We are investigating.