Resolved
Subscription activation times are back to normal.
Monitoring
We deployed a fix and subscriptions are being activated without delays. We're still monitoring.
Investigating
We have observed a number of delayed subscriptions, i.e. subscriptions not transitioning from pending to active state. We are investigating.