Resolved
Google Cloud has informed us the issue with Load Balancer has been resolved.
Monitoring
We have observed short spikes of API 502/504 HTTP errors. We found them to be related to an ongoing Google Cloud incident with Load Balancers and are closely monitoring the situation.
The scale of the problem is very small, affecting around 0.05% of all the requests.