Resolved
We have resolved the issue briefly affecting availability of our API. It was caused by a longer than expected propagation of configuration changes in one of our infrastructure components (Load Balancer).
Investigating
We have observed an increase in API 5xx HTTP errors. We are investigating.