Resolved
We reverted the change that caused the issue. Event listing in Dashboard is working properly and delayed emails were sent out.
Investigating
We're currently investigating an incident related to the event pipeline and related tooling.
As a result, there are currently delays when sending certain email notifications. Dashboard is partially affected as listing events currently doesn't show any events.