Resolved
API performance has now returned to normal and activation performance is restored.
Investigating
We are seeing degraded performance for some API calls with one of our partner networks (p11) - activations may take longer to complete while this issue is ongoing.