Resolved
This incident has been resolved. Roaming service was fully restored for all affected users as of 03:49 UTC, and performance has remained stable since.
Monitoring
Service restoration is progressing for the subset of affected users as expected. The majority of users have already recovered.
Overall roaming service remains unaffected outside of this isolated group.
Identified
Service restoration is progressing as expected for the subset of users affected by this issue. Many of these users have already recovered, and restoration for the remaining users is being rolled out in waves.
Overall service for users roaming on the P11 network remains unaffected outside of this subset.
We will post the next update by 21:00 UTC, or sooner once restoration is complete.
Identified
We are seeing degraded performance since 14:40 UTC for a subset of users on our P11 network while roaming outside of the United States. Domestic usage is not affected.
Our engineering team has identified the root cause and is working on a resolution for the affected users.
We will post the next update by 17:00 UTC, or sooner if the issue is resolved.