T-Mobile Service Outages and API Degradation
Resolved
Feb 14 at 05:18pm UTC
The health of T-Mobile services has been restored. Any pending T-Mobile subscriptions that had accumulated during this incident have been successfully processed and are now active. We will continue to monitor the situation and provide additional updates if necessary.
Affected services
Network Providers
Created
Feb 14 at 09:58am UTC
T-Mobile is currently experiencing a service disruption across their network affecting voice, messaging, data, and high-speed internet services.
These issues are already being worked on by the network and resolving quickly. If any subscribers are experiencing trouble with their service we recommend rebooting their device or toggling airplane mode to re-sync their devices and restore services.
Affected services
Network Providers