Back to overview
Degraded
Email Delivery is delayed
Apr 25 at 01:00pm UTC
Affected services
Connect
Dashboard
Resolved
Apr 25 at 01:42pm UTC
Delivery times are back to normal. We'll continue monitoring the situation.
Affected services
Connect
Dashboard
Updated
Apr 25 at 01:07pm UTC
We identified issues with a third party provider and are in touch with them to resolve the issue.
Affected services
Connect
Dashboard
Created
Apr 25 at 01:00pm UTC
We’re currently experiencing a delay in login code email delivery. We are investigating the issue and will provide updates as we learn more.
Affected services
Connect
Dashboard