Back to overview
Degraded

AT&T Subscription Activations Delayed

Jun 02 at 04:24pm UTC
Affected services
Network Providers

Resolved
Jun 03 at 12:16am UTC

We were able to identify and resolve the issue with AT&T and new subscription activations are proceeding without any significant delays. The backlog of outstanding activations will now be processed. We will continue to monitor the recovery.

Updated
Jun 02 at 07:35pm UTC

We're still continuing to work with AT&T on resolving the current delays with subscription activations. We'll process all pending subscriptions automatically once the root cause is identified and resolved.

Created
Jun 02 at 04:24pm UTC

New AT&T subscription activations are currently delayed due to a service degradation. Once the root cause has been identified and resolved our systems will automatically process all pending subscriptions.