AT&T Subscription Activation Delays
Resolved
Jul 26 at 08:43am UTC
We have resolved the network provider activation delay degradation - all affected subscriptions have now been activated and new subscriptions will activate normally going forward. We apologize for any inconvenience this may have caused you - our team continues to work hard on improvements to reduce the likelihood of any similar future incidents.
Affected services
Network Providers
Updated
Jul 15 at 03:00pm UTC
We've established a temporary solution to the ongoing AT&T service degradation affecting new subscription activations. Starting today, pending AT&T subscriptions will be activated in daily batches.
This is a temporary solution, and we're diligently working on a real-time, permanent fix with AT&T. Expect an update on the long-term solution early next week. Thank you for your understanding and patience.
Affected services
Network Providers
Updated
Jul 14 at 07:32pm UTC
AT&T continues to experience a service degradation, which is causing a delay in the activation of new subscriptions. Our team is working on a fix and hopes to be able to provide an update shortly. Our system will automatically process all pending subscriptions once the issue has been resolved.
Affected services
Network Providers
Updated
Jul 14 at 08:32am UTC
We're still continuing to work with AT&T on resolving the current delays with subscription activations. We'll process all pending subscriptions automatically once the root cause is identified and resolved.
Affected services
Network Providers
Created
Jul 13 at 03:39pm UTC
AT&T is currently experiencing a service degradation, which is delaying the activation of new subscriptions. Our system will automatically process all pending subscriptions once the issue has been resolved.
Affected services
Network Providers