Back to overview
Degraded

Increased Response Times and Timeouts of our API

Sep 10 at 04:29pm UTC
Affected services
API
Connect
Dashboard

Resolved
Sep 10 at 05:18pm UTC

We have identified the root cause and implemented a fix that has returned response times to normal. We continue to closely monitor our services and response times. Thank you for your patience.

Updated
Sep 10 at 05:08pm UTC

Our engineers are still investigating the problem and have taken some initial steps to reduce system load. We will provide an update as soon as we have identified the cause and implemented a fix, but no later than 17:45 UTC.

Created
Sep 10 at 04:29pm UTC

We are currently experiencing increased response times and intermittent timeouts across our API. Our team is actively investigating the issue and working to resolve it as quickly as possible. The degradation of our API also affects Dashboard and Connect.

We apologize for any inconvenience this may cause and will provide updates as soon as more information becomes available. Thank you for your patience and understanding.