Back to overview
Degraded

AT&T Service Degradation

Feb 26 at 07:46am UTC
Affected services
Network Providers

Resolved
Feb 26 at 09:03pm UTC

AT&T has resolved the issue and new subscription activations are being processed normally. Previous activation attempts are being re-processed. We will continue to monitor the recovery.

Updated
Feb 26 at 06:28pm UTC

AT&T has identified the issue and is working to restore service availability. Subscription activations are still experiencing intermittent delays and will be re-processed as soon as possible. We will continue to provide updates as they become available.

Updated
Feb 26 at 03:08pm UTC

We are continuing to see delays with AT&T subscription activations. All delayed activations will be re-processed when the issue has been resolved, we will provide additional updates as they become available.

Updated
Feb 26 at 11:00am UTC

AT&T continues to investigate the issue. We will provide additional updates as they become available.

Created
Feb 26 at 07:46am UTC

AT&T is currently experiencing a service degradation, which is leading to intermittent activation delays. Once the root cause has been identified and resolved our systems will automatically process all pending subscriptions.