Back to overview
Degraded
Invoices not available in Connect
Mar 26 at 12:40am UTC
Affected services
Connect
Resolved
Mar 26 at 05:00am UTC
All systems are back to operational. Invoices can be viewed in Connect again and emails for new invoices are sent again.
There has been no data loss, all invoices created in the affected time window can be viewed through Connect.
Affected services
Connect
Created
Mar 26 at 12:40am UTC
We're investigating an issue that causes invoices not being displayed in Connect. This also affects emails that send the invoices as attachments; these emails are not sent at this time.
Affected services
Connect