Back to overview
Degraded
AT&T Service Degradation
Apr 18 at 09:38am UTC
Affected services
Network Providers
Resolved
Apr 18 at 11:25am UTC
AT&T has resolved the issue and new subscription activations are being processed normally. Previous activation attempts are being re-processed. We will continue to monitor the recovery.
Affected services
Network Providers
Created
Apr 18 at 09:38am UTC
AT&T is currently experiencing a service degradation, which is leading to intermittent activation delays. Once the root cause has been identified and resolved our systems will automatically process all pending subscriptions.
Affected services
Network Providers