Back to overview
Degraded

Delays processing changes to p15 subscriptions

Aug 13 at 09:40am UTC
Affected services
Network Providers

Resolved
Aug 13 at 11:00am UTC

The issue has been resolved and all subscription operations are being processed normally.

Created
Aug 13 at 09:40am UTC

All operations (activations, SIM exchanges, etc.) on subscriptions for provider p15 are currently delayed. Engineers are actively investigating. Once the issue has been identified and resolved, our systems will automatically reprocess all pending operations.