Back to overview
Degraded

Delayed subscription activations affecting roaming provider p15

Dec 24 at 04:45am UTC
Affected services
Network Providers

Resolved
Dec 24 at 06:49am UTC

New activations are proceeding normally and the backlog of activations has been fully processed. We will continue to monitor the recovery.

Updated
Dec 24 at 05:25am UTC

The root cause has been identified and we are working with the provider to resolve the underlying issue. All pending new subscriptions will be processed automatically as soon as normal service is restored.

Created
Dec 24 at 04:45am UTC

We are currently investigating an issue causing delays for new subscription activations on roaming provider p15. Existing subscriptions and active roaming services are unaffected.

Our API and internal systems are operating normally. All pending activations are being queued and will be retried automatically—no manual action is required.

We are working to identify the root cause with the provider and will provide an update shortly.