Back to overview
Degraded
T-Mobile subscription activations delay
May 12 at 08:00pm UTC
Affected services
Network Providers
Resolved
May 12 at 08:45pm UTC
We were informed that the issue has been identified and resolved. All pending subscriptions have been activated during the last 15 minutes. Activations appear to be fully operational again.
Affected services
Network Providers
Created
May 12 at 08:00pm UTC
T-Mobile subscription activations are currently delayed. We opened a high priority support ticket and are waiting for more information and resolution. We'll continue to monitor the situation.
Affected services
Network Providers