Back to overview
Degraded
AT&T subscription activations delay
May 17 at 06:00pm UTC
Affected services
Network Providers
Resolved
May 18 at 04:30am UTC
AT&T was able to resolve the issue, all subscriptions have been activated.
Affected services
Network Providers
Created
May 17 at 06:00pm UTC
We are currently experiencing intermittent AT&T subscription activation failures. We informed the carrier and requested a quick resolution. Subscription activations will resume automatically once the issue has been resolved.
Affected services
Network Providers