Back to overview
Degraded
T-Mobile service incident in the Northeast
May 31 at 06:00pm UTC
Affected services
Network Providers
Resolved
Jun 01 at 08:00pm UTC
T-Mobile was able to resolve the issue. All services should have been restored by now.
Affected services
Network Providers
Created
May 31 at 06:00pm UTC
T-Mobile is experiencing a large incident in the US. Voice, Data, and Messaging services may be temporarily unavailable in the Northeast Region. This includes New York, Long Island, New England, New Jersey, Philadelphia, Virginia, Washington DC and Connecticut. Recovery is still ongoing. We'll provide an update once we receive more information.
Affected services
Network Providers