Back to overview
Degraded
T-Mobile subscription activations delay
Jun 21 at 10:30am UTC
Affected services
Network Providers
Resolved
Jun 21 at 11:08am UTC
The issue has been resolved by T-Mobile.
Affected services
Network Providers
Created
Jun 21 at 10:30am UTC
T-Mobile informed us about intermittent issues processing all kinds of API requests. Subscription activations might take longer than usual. Once the issues have been resolved all subscriptions will be processed automatically. We'll continue monitoring the situation and forward any updates provided by T-Mobile.
Affected services
Network Providers