Back to overview
Degraded

AT&T Subscription Activation Delays

Nov 28 at 07:27am UTC
Affected services
Network Providers

Resolved
Nov 28 at 04:23pm UTC

AT&T has resolved the issue. All pending subscriptions have been processed and all systems are fully operational again.

Created
Nov 28 at 07:27am UTC

AT&T is currently experiencing a service degradation, which is delaying the activation of new subscriptions. Once the issue has been resolved, our system will automatically process all pending subscriptions until they are successfully activated.