T-Mobile and AT&T subscription activations delayed
Resolved
Jan 01 at 11:29am UTC
All pending subscriptions have been processed and all systems are fully operational again. We will work with our vendor to understand the root cause of the issue and how it can be prevented in the future. Thank you for your patience.
Affected services
Network Providers
Created
Jan 01 at 08:59am UTC
Subscription activations for providers T-Mobile and AT&T are currently delayed. We identified a technical problem in a third-party system and escalated the issue to their support team. We're waiting to hear back from them and will continue to monitor the situation.
Once the issue has been resolved our system will automatically process all pending subscriptions until they are successfully activated.
Affected services
Network Providers