Back to overview
Degraded

T-Mobile Service degradation

Oct 09 at 12:09pm UTC
Affected services
Network Providers

Resolved
Oct 09 at 03:07pm UTC

The underlying T-Mobile API issue has been resolved. Pending operations have been successfully processed. We apologize for any inconvenience this issue may have caused you and your team, and thank you for your patience. We will continue to monitor service recovery.

Created
Oct 09 at 12:09pm UTC

T-Mobile is currently experiencing a service degradation, which is delaying the activation of new subscriptions. Our system will automatically process all pending subscriptions once the issue has been resolved.

Our currented estimated resolution time for this is 9am ET.