Back to overview
Degraded

AT&T Subscription Activation Delay

Dec 12 at 04:48pm UTC
Affected services
Network Providers

Resolved
Dec 12 at 10:00pm UTC

Our provider has reported that the issue has been resolved. All pending subscriptions have been processed successfully.

Updated
Dec 12 at 07:22pm UTC

Our provider has identified the underlying issue and is looking to rectify it as soon as possible. We have already seen some service recovery, but will continue to monitor the situation closely until it has been fully addressed.

Created
Dec 12 at 04:48pm UTC

AT&T is currently experiencing a service degradation, which is leading to delayed subscription activations. Once the root cause has been identified and resolved our systems will automatically process all pending subscriptions.